New!

Run a Lucid Systems Check to automatically get a report showing if your system is Lucid-ready.


Lucid Meetings works best with the latest versions of:

  • Chrome
  • Firefox
  • Internet Explorer 10 & 11
  • Safari

Lucid Meetings does not work with IE 9 or earlier, and may not work correctly with browsers others than those listed above.

Plugins

There are no required downloads or plugins for anyone using the core Lucid Meetings product.

Some integrations, such as audio conferencing and screen sharing, may require a plugin. To learn more about the technical requirement for an integration, see the Integrations help.