You need an internet connection and a computer with a modern browser with javascript enabled. Lucid Meetings works best with the latest versions of:

  • Chrome
  • Firefox
  • Internet Explorer 10 & 11
  • Safari

Lucid Meetings does not work with IE 8 or earlier, and may not work correctly with browsers others than those listed above.

To use the built-in web audio, you must have a browser that supports WebRTC such as Chrome or Firefox.

If you'll be sharing your screen, you will also need to install a plugin from Glance. Glance screen sharing runs on both Windows and MacOS X. You do not need to install Glance to view a shared screen, though. Screen sharing is available with paid subscriptions only. See Screen Sharing by Glance for more details.

To see if your system is set up to work with Lucid Meetings, visit our Browsers and Plugins test page.